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Introduction

To all residents of the European Union

Important environmental information about this product

This symbol on the device or the package indicates that disposal of the device after its lifecycle could harm the environment.
Do not dispose of the unit (or batteries) as unsorted municipal waste; it should be taken to a specialized company for
recycling. This device should be returned to your distributor or to alocal recycling service. Respect the local environmental
rules.

If in doubt, contact your local waste disposal authorities.

Thank you for choosing Whadda! Please read the manual thoroughly before bringing this device into service. If the device
was damaged in transit, do not install or use it and contact your dealer.

Safety Instructions

L]

Read and understand this manual and all safety signs before using this appliance.

For indoor use only.

e This device can be used by children aged from 8 years and above, and persons with
reduced physical, sensory or mental capabilities or lack of experience and knowledge if
they have been given supervision or instruction concerning the use of the device ina
safe way and understand the hazards involved. Children shall not play with the device.
Cleaning and user maintenance shall not be made by children without supervision.

General Guidelines

. Refer to the Velleman® Service and Quality Warranty on the last pages of this manual.

e  Allmodifications of the device are forbidden for safety reasons. Damage caused by user modifications to the device is
not covered by the warranty.

. Only use the device for its intended purpose. Using the device in an unauthorised way will void the warranty.

. Damage caused by disregard of certain guidelines in this manual is not covered by the warranty and the dealer will not
accept responsibility for any ensuing defects or problems.

. Nor Velleman nv nor its dealers can be held responsible for any damage (extraordinary, incidental or indirect) - of any
nature (financial, physical...) arising from the possession, use or failure of this product.

. Keep this manual for future reference.

What is Arduino®

Arduino’ is an open-source prototyping platform based on easy-to-use hardware and software.
Arduino® boards are able to read inputs - light-on sensor, a finger on a button or a Twitter message -
and turn it into an output - activating of a motor, turning on an LED, publishing something online. You
can tell your board what to do by sending a set of instructions to the microcontroller on the board. To
do so, you use the Arduino programming language (based on Wiring) and the Arduino” software IDE
(based on Processing). Additional shields/modules/components are required for reading a twitter
message or publishing online. Surf to www.arduino.cc for more information
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Product overview

The Whadda WPB109 ESP32 development board is a comprehensive development platform for Espressif’s
ESP32, the upgraded cousin of the popular ESP8266. Like the ESP8266, the ESP32 is a WiFi-enabled
microcontroller, but to that it adds support for Bluetooth low-energy (i.e BLE, BT4.0, Bluetooth Smart), and 28
I/0 pins. The ESP32’s power and versatility makes it the ideal candidate to serve as the brains of your next loT
project.

Specifications:

Chipset: ESPRESSIF ESP-WROOM-32 CPU: Xtensa dual-core (or single-core) 32-bit LX6 microprocessor
Co-CPU: ultra low power (ULP) co-processor
GPIO Pins 28

Memory:

RAM: 520 KB of SRAM ROM: 448 KB
Wireless connectivity:

WiFi: 802.11 b/g/n

Bluetooth®: v4.2 BR/EDR and BLE

Power management:

max. current consumption: 300 mA

Deep sleep power consumption: 10 pA
max. battery input voltage: 6 V

max. battery charge current: 450 mA

Dimensions (W x L x H): 27.9 x 54.4.9 x 19mm
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Functional overview
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Boot Button

O O D4 016 017106 D18 019 GO 021

RDONDONZ2I2.30M0
IOOEOEOOTOODOLS

PO os

9200 G20 OIZETI K0 YOO NAS S N3 S/
; gL

ESP32-WROOM-32

USB-to-UART Bridge

Key Component

Description

ESP32-WROOM-32

A module with ESP32 at its core.

EN Button

Reset button

Boot Button

Download button.

Holding down Boot and then pressing EN initiates
Firmware Download mode for downloading
firmware through the serial port.

USB-to-UART Bridge

Converts USB into UART serial in order to
facilitate the communication between the ESP32
and pc

Micro USB Port

USB interface. Power supply for the board as well
as the communication interface between a
computer and the ESP32 module.

3.3 V Regulator
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Getting started

Installing the required software
1. First, make sure you have the latest version of the Arduino IDE installed on your computer. You can
download the latest version by going to www.arduino.cc/en/software.
2. Open the Arduino IDE, and open the preferences menu by going to File > Preferences. Enter the
following URL into the "Additional Boards Manager URLs" field:
https://raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package esp32 index.json, and

Preferences x

Settings  Network

Sketchbook location:

C:Wsersmidas\DocumentsArduino| Erowse
Editor language: System Default ~ | (requires restart of Arduin)

Editor font size: 14

Interface scale: [] Automatic | 100 5 [% (requires restart of Arduino)

Theme: Default theme + | (requires restart of Arduino)

Show verbose output during: 7] compilation [7] upload

Compiler warnings: None

Display line numbers []Enable Code Folding

Verify code after upload [ Use external editor

Check for updates on startup Save when verifying or uploading

[ Use accessibilty features

Additional Boards Manager URLs: |son, https: /jraw.githubusercontent. com//espressiffarduino-esp32/gh-pages/package_esp32_index.json | 1
More preferences can be edited directly in the file
— C:\Users\midas\AppData.ocal\Arduino 15\preferences. tet
{edit only when Arduino is not running)
hlt ”O K” oK Cancel
3. Open the Boards Manager from Tools > Board menu and install the esp32 platform by putting ESP32
into the search field, selecting the most recent version of the esp32 core (by Espressif Systems), and
clicking "Install".

@ Boards Manager *
Type Al « | |ESP32
esp32 ~

by Espressif Systems

Boards included in this package:

ESP32 Dev Module, WEMOS LoLin32, WEMOS D1 MINI ESP32.
More Info

8w

Close
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Uploading the first sketch to the board
4. Once the ESP32 core has been installed, open the tools menu and select the ESP32 Dev module board by

going to: Tools > Board:"..." > ESP32 Arduino > ESP32 Dev Module

@ SimpleWiFiServer | Arduino 18,13
File Edit Sketch TnnlsﬂHeIp

Arduina Uno on COM14

ESP32 Dev Module
ESP32 Wrover Module
ESP32 Pico Kit
TinyPICO

MagicBit

Turta loT Node

TIGO LoRa32-OLED V1
TGO TI

XinaBox CW02
SparkFun ESP32 Thing

Auto Format Ctrl+T
Archive Sketch u-blox NINA-W10 series (ESP32)
SimpleWiFiSe{  Fix Encoding & Reload doe= Rl
25 Manage Libraries... Ctrl+Shifts| A Electronic SweetPeas - ESP320
2¢ Serial Monitor Ctrl+ Shift«M Nano32
27 Serial Plotter Ctrl+ShiftL Hedhines
28 #includy LOLIN D32 PRO
WIFi101 / WiFiNINA Firmware Updater S o
ESP32 Sketch Data Upload Dongsen Tech Pocket 32
] ESP8266 LittleFS Data Upload WeMos WiFi&Bluetooth Battery
= - ESPea32
Board: “Arduino Uno” Boards Manager... N
i) Z:LB coM14 Arduino ARM (32-bits) Boards T Nodes
et oard Info Arduino AVR Boards Hombill ESP32 Dev
Seri  Programmer: "USBasp" AiuncimeqahVe Boaids " Hornbill ESP32 Minima
pindl | Bih Bastioader SRS | FireBeetle-ESP32
ESP8266 Boards (2.74) IntoRobot Fig
delay(10); STM32F1 Boards (STM32duino.com) 7 gnenorse ESP32 Dev Module
£ 2 Adafruit ESP32 Feather
NodeMCU-325
MH ET LIVE ESP32DevKIT
MH ET LIVE ESP32Minikit
£5P32vn loT Uno
DOIT ESP32 DEVKIT V1

OLIMEX ESP32-EVB

5. Connect the Whadda ESP32 module to your pc using a micro USB cable. Open the tools menu again and
check if a new serial port has been added to the port list and select it (Tools > Port

.7 > ). If this is not

the case, you may need to install a new driver to enable the ESP32 to properly connect to your

computer.

Go to https://www.silabs.com/developers/usb-to-uart-bridge-vcp-drivers to download and install the

driver. Reconnect the ESP32 and restart the Arduino IDE once he process has finished.

WIFi101 / WiFiNINA Firmware Updater

ESP32 Sketch Data Upload
ESP2266 LittleFS Data Upload

Programmer

Burn Bootloader

s )

«T
Board: "ESP32 Dev Module” » ‘ g
Upload Speed: "256000" > [ §
CPU Frequency: "240MHz (WiFi/BT)" ¥ ; o3’
Flash Frequency: "80MHz" > i é‘
Flash Mode: "QIO" b ‘ g :
Flash Size: "4MB (32Mb)" » i £ g ;-
Partition Scheme: "Default 4ME with spiffs (1.2MB APP/1.5MB SPIFFS)" > ‘@8
Core Debug Level: "None" » @ g
PSRAM: "Disabled” > i @g
Port: "COM14" : Serial ports | @8
Get Board Info ¥ coms ®

@ SimpleWiFiServer | Arduino 1.8.13 = m] K
File Edit Sketch Tools Help |
Auto Format Ctrl+T
| Archive Sketch

SimpleWiFisel Fix Encoding & Reload

25 Manage Libraries... Ctrl+Shift+| SPRESSIF

7: Serial Monitor Ctrl+Shift+ M ES?%Z-WROOM

1 Serial Plotter Ctrl+Shift+L

OPPEEOOPOLOEY
zmgcaﬁm MS:YS. IGE‘AS

016 017105 0181019 GND 1021 RXDOTDOD220Z3RD

(CHGRINCACHCA N ONORUROR NN NN

]

Boot button
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6. Check that the following settings have been selected in the tools board menu:

Auto Format Crl+T
Archive Sketch

Fix Encoding & Reload

Manage Libraries... Ctrl+Shift+|
Serial Monitor Ctrl+Shift+M
Serial Plotter Ctrl+Shift+L

WiFi101 / WiFiNINA Firmware Updater

ESP32 Sketch Data Upload
ESP8266 LittleFS Data Upload

Board: "ESP32 Dev Module"

Upload Speed: "256000"

CPU Frequency: “240MHz (WiFi/BT)"
Flash Frequency: *80MHz"

Flash Mode: Q10"

Flash Size: "4ME (32Mb)"

Partition Scheme: “Default 4MB with spiffs (1.2MB APB/1.5MB SPIFFS)"
Core Debug Level: “None"

PSRAM: Disabled”

Port: *COM14"

Get Board Info

Programmer >

7. Select an example sketch from the “Examples for ESP32 Dev Module” in File > Examples.
We recommend to run the example called “GetChiplID” as a starting point, which can be found under
File > Examples > ESP32 > ChiplID.

@ GetChiplD | Arduino 1.8.13 - O X
File Edit Sketch Tools Help
New Ctrl+N A
Open... Ctrl+0 Temboo >
Open Recent b WiFi101 * M
Sketchbook b RETIRED ¥ ~
EGiS Examples for ESP32 Dev Module
Close Ctrl+W ArduinoOTA 5
Save ctrleS BluetoothSerial >
Save As... Ctrl+Shift+5 DNSServer 5
Page Setup  Ctrl+5Shift+P EEPROM *
Print Ctrl+P EsP32 : AnalogQut  »C ad
ESP32 Async UDP ; Camera il /e
Preferences  Cirl+Comma ESP32 Azure loT Arduino i Chipld ! GetChiplD
Quit Ctrl+Q E5P32 BLE Arduino 1 DeepSleep  * |

8. Click the Upload button (), and monitor the info messages at the bottom.
Once the message “Connecting...” appears, press and hold the Boot button on the ESP32 until the
uploading process has finished.

Module on COM14

Press and hold Boot button

ev Module on COM14

Release Boot button
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9. Open the serial monitor (.), and check that the baudrate is set to 115200 baud:

D comia — [m] .

Send

[ Autoscrall [] Show timestamp Newline v I 115200 baud I Clear output

10. Press the Reset/EN button, debug messages should start appearing on the serial monitor, together with
the Chip ID (If the GetChipID example was uploaded).

' &
D
€
€
)
©
€
[
©

B0EPOLHWEO®EE EOLOE
QM0 £ 205 €101 NDZ11 Y401 (2010 S20 Y50 S50 3

EN button
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@ comia — ] b4

| | I

ets Jun 8 2016 00:22:57

rst:0xl (POWERON_RESET) ,boot:0xl3 (SPI_FAST FLASH BOOT)
configsip: 0, SPIWP:(Oxee

clk drv:0x00,q drv:0x00,d drv:0x00,cs0_drv:0x00,hd drv:0x00,wp drv:0x00
mode:DI0O, clock div:l

load:0x3£££0018, len:4

load:0x3£££001c, len: 1216

ho 0 tail 12 room 4

load:0x40078000, len: 9720

ho 0 tail 12 room 4

load:0x40080400, len: 6352

entry 0x400806b8

ESP32 Chip ID = 60ET1312CFR4

ESP32 Chip ID = 60ET1312CFR4

ESP32 Chip ID = €0ET1312CFR4 v

[ Autoscrall 7] Show timestamp Mewline - | ‘ 115200 baud ‘ | Clear output

3.3 V Regulator

EN Button
Micro USB Port ———® =& % sl ™ = Ul B ESP32-WROOM-32

Boot Button

018 017106 D18 019 GND 021

FODODDOOZ2102.30N0
COOOOTIOODOLS

USB-to-UART Bridge

v | , Having trouble?

O Restart the Arduino IDE and reconnect the ESP32 board. You can check if the driver has been

= properly installed by checking Device manager on Windows under COM Ports to see if a Silicon Labs
CP210x device is recognized. Under Mac OS you can run the command 1s /dev/{tty.cu}.xin

m the terminal to check this.

mo
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WiFi connection example

The ESP32 really shines in applications where WiFi connectivity is required. The following example will harness
this extra functionality by having the ESP module function as a basic webserver.

1. Open the Arduino IDE, and open the AdvancedWebServer example by going to File > Examples >
WebServer > AdvancedWebServer

@ AdvancedWebServer | Arduino 1.8.13 = a x

File Edit Sketch Tools Help

New Ctrl+N
Open... Ctrl+Q
Open Recent >
Sketchbook > el
Examples A
T T Adafruit Circuit Playground >
Save Ctrl+S Bndoe {
SaveAs..  CtrlsShiftsS Ethemet i
Firmata >
PageSetup  Ctrl+Shift+P LiquidCrystal >
Print Ctrl+P NTPClient 2 LhE
Preferences  Ctrl+Comma =0 2
Stepper >
Quit Ctrl+Q Temboo >
S i R WiFi101 >
13 other material RETIRED -

Examples for ESP32 Dev Module
ArduincOTA
BluetoothSerial
DNSServer

EEPROM

ESP32

ESP32 Async UDP

ESP32 Azure loT Arduino
ESP32 BLE Arduino
ESPmDNS

FFat

HTTPClient

HTTPUpdate

NetBIOS

Preferences

SD(esp32)

SD_MMC
SimpleBLE HttpAdvancedAuth

- HttpBasicAuth

AdvancedWebServer

bitts @211

FSBrowser

HelloServer

SPIFFS PathArgServer

Ticker SDWebServer

Update SimpleAuthentification

WebServer WebUpdate

WiFi >
"]

2. Replace YourSSIDHere with your own WiFi network name,
and replace YourPSKHer e with your WiFi network password.

L

31l #include <WiFi.h>

32 |#include <WiFiClient.h>

33 #include <WebServer.h>

34 #include <ESPmDNS.h>

36 const char *ssid = "YourSSIDHere™;

37 const char *password = "YourPSEHere";
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3. Connect your ESP32 to your pc (if you haven’t already), and make sure that the correct board settings in
the Tools menu are set and that the proper serial communication port has been selected.

Auto Format Ctrl+T
Archive Sketch
Fix Encoding & Reload

Manage Libraries... Ctrl+Shift+1
Serial Monitor Ctrl+Shift+ M
Serial Plotter Ctrl+Shift+L

WiFi101 / WiFiNINA Firmware Updater

ESP32 Sketch Data Upload
ESP8266 LittleFS Data Upload

Board: 'ESP32 Dev Medule
Upload Speed: "256000"

CPU Frequency: *240MHz (WiFi/BT)*

Flash Frequency: "20MHz"

Flash Mode: "QI0*

Flash Size: "M (32Mb)"

Partition Scheme: “Default AME with spiffs (1.2MB APP/1.5ME SPIFFS)"
Core Debug Level: "None"

PSRAM: “Disabled”

Port: "COM14"

Get Board Info

Programmer >

Burn Bootloader

4. Click the Upload button (.), and monitor the info messages at the bottom.
Once the message “Connecting...” appears, press and hold the Boot button on the ESP32 until the
uploading process has finished.

AV W~

| €SPRESSIF .
A 5| ESP32-WROOM-32 J
i % | @ CE @ al
qa | o [T =
(2% =
9 GJ:
Press and hold Boot button i &

®

1015 02 00 04 016 017105 0181019 GND mmmmm

OO GO

Module an COM14

Release Boot button

Boot button
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5. Open the serial monitor (.), and check that the baudrate is set to 115200 baud:
© coms — ] x

Send

Autosaroll [ Show timestamp Newline w l 115200 baud - | Clear output

6. Pressthe Reset/EN button, debug messages should start appearing on the serial monitor, together with
status info about the network connection and the IP-address.

Take a note of the IP address:
© comis ' T T«

Send

rst:0xl (POWERON RESET),boot:0x13 (SPI_FAST FLASE BCOT) B cspressiF
ESP32-WROOM

configsip: 0, SPIWP:Oxee
clk drv:0x00,q_drv:0x00,d drv:0x00,c50_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIC, clock diw:l

load:0x3f££f0018, len:4 e -
load:0x3fff001c, len: 1216 QE
ho 0 tail 12 room 4 ®§ .
load:0x40078000, len: 9720 @§
ho 0 tail 12 room 4 ®§ 3
load:0x40080400, len: 6352 @3 b
entry 0x400806h8 3
@3
@3
Connected to = .5
TP add 192.168 ) &z
address: . .
(@8
MDNS responder started @g
HTTP server started |
v 1@8
[ Autosaroll [] Show timestamp Newline ~ | 115200 baud Clear output D ¥
EN button

~ Is the ESP32 having trouble to connect to your WiFi network?

Check that the WiFi network name and password have been set up correctly, and that the ESP32 is
in range of your WiFi access point. The ESP32 has a relatively small antenna so it might have more
difficulties to pick up the WiFi signal at a certain location than your PC.

&
O
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7. Open our web browser and try to connect to the ESP32 by entering it’s ip addresses in the address bar.
You should get a webpage that shows a randomly generated graph from the ESP32

@ ESP32 Demo x +

“—

C t A Notsecure | 192.168. 58

Hello from ESP32!

Uptime: 00:30:01

What to do next with my Whadda ESP32 board?

Check out some of the other ESP32 examples that come preloaded in the Arduino IDE. You could try
out the Bluetooth functionality by trying the example sketches in the ESP32 BLE Arduino folder, or
try out the internal magnetic (hall) sensor test sketch (ESP32 > HallSensor). Once you tried out a
few different examples you can try to edit the code to your liking, and combine the various
examples to come up with your own unique projects!

Also check out these tutorials made by our friends at last minute engineers:
lastminuteengineers.com/electronics/esp32-projects/
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Modifications and typographical errors reserved - © Velleman Group nv, Legen Heirweg 33 - 9830 Gavere
WPB109-26082021.
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